TCCoA Forums banner

1 - 20 of 22 Posts

·
Administrator
Joined
·
8,054 Posts
Looks like the purge valve. The line to it probably rotted and broke off. You throwing and codes?

Joe
 

·
Registered
Joined
·
1,863 Posts
Check engine light may be burned out. You should have a code for that. Hell, if you fart near the EVAP system, or don't tighten the gas cap to 40 ft/lb, it will throw a code for 2 months. Touchy damn system for sure, not just T-Birds.

Al
 

·
Registered
Joined
·
57 Posts
Discussion Starter #5 (Edited)
Check engine light may be burned out. You should have a code for that. Hell, if you fart near the EVAP system, or don't tighten the gas cap to 40 ft/lb, it will throw a code for 2 months. Touchy damn system for sure, not just T-Birds.

Al
The light comes on before I start the car so I know the light functions. I haven't looked into it farther than that. How could I confirm that it is functioning correctly?
 

·
Registered
Joined
·
3,762 Posts
That is for sure part of the EVAP system. The canister is right there behind the bumper support. All of my rubber hoses were rotten. I'm not sure about why it's not throwing a code though.

Part #4 in this drawing.
 

Attachments

·
Registered
Joined
·
57 Posts
Discussion Starter #7
Thanks for all of the good info. I'm still stumped as to why it doesn't throw codes. The cats are crumbling apart from age I figured that would throw a code of some sort as well.
 

·
Registered
Joined
·
3,762 Posts
Where is the flow sensor on the 96-7? That diagram is from the 1997 FSM. I think the other side of the port may be broken off on OP's part.
 

·
Super Moderator
Joined
·
17,043 Posts
Where is the flow sensor on the 96-7? That diagram is from the 1997 FSM. I think the other side of the port may be broken off on OP's part.
It's not in it, the sensor is directly next to the purge valve, on the intake side, on 96-97s.

By the looks of it that image was simply reused between the 94 and 97 FSMs, and that addition was simply overlooked. The coil pack location, FPR placement, and wire harness layout are all specific to the 94/95 in that image.
 

·
Super Moderator
Joined
·
10,651 Posts
It being an open vacuum line straight into the throttlebody, yeah, it could do that. :)
 

·
Registered
Joined
·
57 Posts
Discussion Starter #15
Update: i ran into some suspension troubles and had to replace tie rod ends, while doing so i attempted to put the EVAP system back in order. I found a small line between a metal line and a hard plastic line under the air filter. I replaced that, while fiddling with this i noticed one side of the purge valve is broken off. Can i still buy them from ford and try to get this fixed? The high idling has wrecked my trans fluid, im worried this stupid vaccum line is going to cost me a transmission.
 

·
Registered
Joined
·
410 Posts
And the lack of that sensor is why NJ wouldn't let a 1994/1995 use OBD-II to pass smog on the 4.6L. I asked. Now it is a moot point as 1995 and earlier don't get smogged at all.
 

·
Registered
Joined
·
2,894 Posts
Thats funny because when I had my 94 in the early 2000s, MD plugged it in to'smog' it.
 

·
Registered
Joined
·
57 Posts
Discussion Starter #19
Once i got the old valve off it threw code p0443 i got another valve and found its home. It helped a little, when i park the car it idles up to 1500 then back down to 1300. When cold it began at 950, slowly creeping up to 1300rpm at operating temp. Any tips on what to do next?
 

·
Super Moderator
Joined
·
10,651 Posts
1 - 20 of 22 Posts
Top