TCCoA Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter #1
well i threw the code po340, CAMSHAFT POSITION SENSOR malfunction,, so i bought the sensor, i got home opened my hood and have no clue where the h*** the sensor is.. i think i found the cranshaft position sensor right next to the a/c compressor, it resembles the camshaft sensor but its not the same,,, autozone told me the sensor is located in the center, upper part of the engine below the ignition coil??? i looked and there is nothing to be found.if anyone knows the real location of the sensor please help , i would really appreciate it. thanks
 

·
Registered
Joined
·
12 Posts
dirtydog,
I've never seen one of these. Can you be a little more descriptive? this will be the first time I replace one if I find it.

alanis
 

·
Premium Member
Joined
·
6,617 Posts
Find the waterpump, look up above it on the engine. Between the intake and the waterpump ...basically. If I was standing in front of the car I'd reach my arm out and point.
Alan
 

·
Newbie
Joined
·
5,650 Posts
alanis, you should keep your questions to one section. It's not necessary to go to every section where a cam sensor was every talked about and ask around. Your question will get answered and posting everywhere won't make it happen any faster. And it doesn't look good.
 

·
Premium Member
Joined
·
6,617 Posts
I saw the other thread that might be right the last one I did was a 96.
I don't own a 3.8 car anymore and the last one I did had a distributor.
Alan
 

·
Registered
Joined
·
12 Posts
PHP:
alanis, you should keep your questions to one section. It's not necessary to go to every section where a cam sensor was every talked about and ask around. Your question will get answered and posting everywhere won't make it happen any faster. And it doesn't look good.
__________________
Chris my apologies for posting my question on multiple sections. To make a long story short I was getting impatient as I really wanted to get this done as my state inspection sticker has been expired for a while now. Thought the more I put it out there the better my chances that somebody that knew where it is would see it.

Once again thanks for your help. I did everything you instructed me to do and the codes are gone. A new one just popped out which I'm about to post for help. Please help if you can.
 
1 - 12 of 12 Posts
Top