TCCoA Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
408 Posts
Discussion Starter #1
I have 166k on my 96 v8. Sometimes when I turn the wheel it winds like a metal on metal grinding. The only suspension part thats bad is the strut rod bushing to the control arm. Could a clogged filter be keeping fluid from flowing causing the whining? I recently flushed the fluid and it was thick and viscous and BLACK.
 

·
Registered
Joined
·
320 Posts
If you are gonna go to that extent you might as well get that old nasty fluid out of there. The fluid should be red or clear. Not black. If you find that is isn't an air problem then it might be the pump or even the Rack that is causing the noise.
 

·
Registered
Joined
·
1,747 Posts
add some lucas power steering additive too
 

·
Registered
Joined
·
573 Posts
Sounds like you have a PS leak. Black is not a good color for car fluids. It indicates contamination. @166,000 miles I would bet the whole system needs to be replaced to insure the job is right.
 

·
Registered
Joined
·
408 Posts
Discussion Starter #8
So I did some tracing on the lines and theres some cracks in them at one point, I'm thinking this is my issue. I'm completely redoing the system.
 

·
Registered
Joined
·
573 Posts
A lot of guys go to Jason @ the Ford parts counter on site. I deal with an online Ford dealer out of Dallas. Both have prices that compare with Auto Zone but you get genuine Ford parts to boot. Do not just walk into a Ford dealer and buy unless you are in a pinch. Order the parts and in one week they will be on your door step. Not all parts are still made but you will be surprised at what is still at hands reach. This is not a cheap hobby but it is rewarding when done right.
 
1 - 10 of 10 Posts
Top