TCCoA Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
1,742 Posts
Discussion Starter #1
my buick has a 3.8 v6. it has 3 coil packs. by the coils there is a little box with vaccum lines in it. see pic. it is circled ;)

i replaced the one line yesterday and bumped the end and noticed it turned. so i took off the little cap and inside there was this little filter. it pretty much falls appart as u touch it.

now does anybody know what it is? should i worry about it since i hate the car and only use it cause my bird is under construction?
 

·
Registered
Joined
·
814 Posts
It's an electric vacuum switch. Maybe to your fuel regulator or EGR? Nothing to worry about unless it is leaking vacuum, which will cause it to run lean a little.
 

·
Registered
Joined
·
1,024 Posts
Drnaline said:
It's an electric vacuum switch. Maybe to your fuel regulator or EGR? Nothing to worry about unless it is leaking vacuum, which will cause it to run lean a little.
I would say egr because of the filter.....

Probably the egr modulator or whatever gm calls it
 

·
Registered
Joined
·
814 Posts
Your probably right. But i do know that some regulators which is right there too are vented to the atmosphere at WOT(wide open throattle) and regulated almost closed at idle. It's knida hard to tell with the graininess of the pic.
 

·
Registered
Joined
·
1,742 Posts
Discussion Starter #6
yea im sorry my camera is a p.o.s. i know when i first got it, it ran opretty good but it seems to have lost some grunt. i found some coolant laying around the head but its not throwin it out the exhaust. if more pics r needed i can do it. it just that my camera sucks. ;)
 

·
Registered
Joined
·
814 Posts
No problem, it was nice to include a pic, my camera is the same. One of those phone ones is the closest i get to digital.
 

·
Registered
Joined
·
1,024 Posts
thunderbirdlver said:
yea im sorry my camera is a p.o.s. i know when i first got it, it ran opretty good but it seems to have lost some grunt. i found some coolant laying around the head but its not throwin it out the exhaust. if more pics r needed i can do it. it just that my camera sucks. ;)

Lower intake gasket is bad ;) All the little gm pushrod v6's get that
 

·
Registered
Joined
·
1,742 Posts
Discussion Starter #9
u know it has had an upper engine knock since like 2 weeks after i got it. we thought it was a rod bearing but it never gets loud plus it would have died by now. it actually might not b as loud as when it started. so could the upper knock b related to the coolant leak? it also stalls if u put it in gear before letting it run for a few mins. just for the heck of it all ive done was change the plug and wires, and a junkyard radiator i paid 30 bucks for. it really paid off too. ;) i made sure it wasnt leaking though. hope the new info helps and i can fix it without breaking into my account ;)
 

·
Registered
Joined
·
1,024 Posts
thunderbirdlver said:
u know it has had an upper engine knock since like 2 weeks after i got it. we thought it was a rod bearing but it never gets loud plus it would have died by now. it actually might not b as loud as when it started. so could the upper knock b related to the coolant leak? it also stalls if u put it in gear before letting it run for a few mins. just for the heck of it all ive done was change the plug and wires, and a junkyard radiator i paid 30 bucks for. it really paid off too. ;) i made sure it wasnt leaking though. hope the new info helps and i can fix it without breaking into my account ;)

Well it's a known issue on those motors, and if you leave it to long the coolant in the oil ruins the bearings - might be your knock......


Sorry to be the bearer of bad news.

Good news is a bearing set and the gasket are cheap
 

·
Registered
Joined
·
1,742 Posts
Discussion Starter #11
ok new info! i thought i should look while its running. its leaking coolant from the middle of the back of the engine. looks like its coming out of a gasket. im not 100% sure though yet. it was raining and i was in a bar parking lot. so my new question is does anybody know what i need to do? id like to fix it myself to save cost. anything i can do to help answer the question is no problem ;)
 

·
Registered
Joined
·
1,024 Posts
thunderbirdlver said:
ok new info! i thought i should look while its running. its leaking coolant from the middle of the back of the engine. looks like its coming out of a gasket. im not 100% sure though yet. it was raining and i was in a bar parking lot. so my new question is does anybody know what i need to do? id like to fix it myself to save cost. anything i can do to help answer the question is no problem ;)


Kentwood said:
Lower intake gasket is bad ;) All the little gm pushrod v6's get that

...
 

·
Registered
Joined
·
1,742 Posts
Discussion Starter #13
ok i figured on that from the earlier post but i wanted to make sure. im gonna get me a book on the beast and see what i gotta do. thanks a lot kentwood and everybody else! ;)
 

·
Registered
Joined
·
1,742 Posts
Discussion Starter #14
well firday i took off the throttle body and found out it was caked with crap on the other side of the butterfly but also, engine coolant runs through the throttle body. so i replaced all 3 lines and no more leaks!!! all that worry for nothing. now im thinkin the MAF is on the fritz since it has a black tacky coating. it seems to run a little rich.
 
1 - 14 of 14 Posts
Top