TCCoA Forums banner

1 - 20 of 22 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
I have a 95 tbird and When the tranny is cold it will shift 1st-4th but when it gets warmed up it only shifts 1st and 2nd. I changed the solenoid, filter, gasket, and fluid and now it does this and leaks. Anyone know whats up? I think i can fix the leak with tightening the pan some more but im more worried about the shifting problem.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #3
No before it only shifted in 2nd and 3rd. Thats why i changed the solenoid pack. Now it work only when its cold and when it gets warm it goes into neutral instead or 3rd or OD.
 

·
Premium Member
Joined
·
5,862 Posts
Patience

Patience, young Jedi. Most people use computers as the tool they are and most likely haven't seen your question yet. The suggestions with come, they just take longer than 24 hours - this isn't cha-cha or KGB.....lol

Personally, I don't have any good ideas or I would have already told you.
 

·
Registered
Joined
·
4,146 Posts
Have you been reading through the Transmissions 101 article ??
Check the Common Problems, and Diagnosing Transmissions Problems sections of the 101 article.

Im thinking ... failing Intermediate one way clutch based on what you have described.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #8
Alright got under the car today and fixed the leak. Then i took it for a 10 in drive and everything was working perfect. When the car warmed up and i accelerated harder, when in OD it just went to neutral. This time i kept 3rd though. And also is there too much oil in when i take out the dipstick and the fluid goes half way up the dipstick? Thanks
 

·
Registered
Joined
·
124 Posts
When a transmission is overfilled the oil gets aerated ( full of bubbles) and can cause erratic shifts. Could this be your problem? yes. am i 100 % sure? no. is their a bunch of bubble's in the fluid when you check it?
 

·
Registered
Joined
·
42 Posts
Discussion Starter #14
Well i just checked and there were no bubbles on the dipstick but fluid was on it all the way up to the middle. Would I have to drain all the fluid and get more or can i reuse it? Cause its pretty expensive for mercon v. Or what do you recommend i do about it?
 

·
Registered
Joined
·
4,146 Posts
Did you drain the TC also ? Or just drop the pan and fill it up with 8 quarts ?

Do you still have the stock 95 pan, or the 96 + ?
 

·
Registered
Joined
·
42 Posts
Discussion Starter #16
Did you drain the TC also ? Or just drop the pan and fill it up with 8 quarts ?

Do you still have the stock 95 pan, or the 96 + ?
No i didnt drain the TC, and i did just drop the pan and add 8 quarts. I also have the 95 pan and flter. I just drained most of the extra tranny fluid and i have the same problem. I think it needs a rebuild or replace. :( I dont have the money for either
 

·
SuperNewbie
Joined
·
2,869 Posts
So cold it goes 1-2-3-4, but warm is goes 1-2- and then NEUTRAL....if that is the case, that is bad, and a sign of direct clutch death.
Agreed.
What did the fluid look like when you first dropped the pan? Was there a bunch of crap built up on the magnet?
Maybe go find yourself a good used tans from the junkyard.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #19
First time i dropped it the magnet had alot of black build up on it. So do you think that i should just get a used 95 tranny for 250 at my local junkyard? What would be the best option?
 

·
Registered
Joined
·
4,146 Posts
If you plan on keeping the car - buy a good transmission or have one built up.

If you dont care and plan on getting rid of the car .. junkyard transmission might work for a little while.
 
1 - 20 of 22 Posts
Top