TCCoA Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
239 Posts
Discussion Starter #1
OK, probably ever since i have had the car which is about a year now, it will what i think detonate every now and then at WOT. now i don't know for sure if it is detonation so i'll describe what i hear.

At WOT everynow and then it will sound like a can of rocks being shaken around, i usually back off of the throttle but if i floor it again the sound usually comes back. Now is this detonation?? I pulled the plugs today, i am running autolite platinums(same temp range i assume because when i bought them it was just for the 4.6 and i didn't know about changing the temp range, and the plugs seemed to have a small amount of white-ness just covering the side electrode(L thingy). I haven't had the plugs in for more than 3000 miles. From what i understand this means i am running a little hot, so should i go a step colder?
If i change to colder plugs do you think this will help my running hot problem. And if i do what corresponding autolite plug should i go with? Or is their another problem i should address.



tony
 

·
Amateur Expert
Joined
·
1,662 Posts
It wouldn't hurt to use the 22C plugs or equivalent. I'm using the AGSF-12FM1 plugs from the Lightning and it totally stopped the detonation I was having post headswap. Also - be sure your MAF is clean and your combustion chambers are free of excess carbon buildup. I use Chevron with Techron twice a year to keep the heads and pistons clean, and they were when I took it apart in March.
 

·
Registered
Joined
·
292 Posts
I second the MAF idea. especially if you have a K&N filter. cleaning mine with windex or Eagle 20/20 fixed all the audible pinging at WOT.
 
1 - 4 of 4 Posts
Top